Archicad 28 C++ API
|
Contains the Structural Analytical Model Analytical Support values. More...
#include <APIdefs_AnalyticalElements.h>
Public Attributes | |
API_AnalyticalRigidityType | xType |
Translation type in X direction. | |
double | xValue |
Translation value in X direction in case of Custom type. | |
API_AnalyticalRigidityType | yType |
Translation type in Y direction. | |
double | yValue |
Translation value in Y direction in case of Custom type. | |
API_AnalyticalRigidityType | zType |
Translation type in Z direction. | |
double | zValue |
Translation value in Z direction in case of Custom type. | |
API_AnalyticalRigidityType | rxType |
Rotation type in X direction. | |
double | rxValue |
Rotation value in X direction in case of Custom type. | |
API_AnalyticalRigidityType | ryType |
Rotation type in Y direction. | |
double | ryValue |
Rotation value in Y direction in case of Custom type. | |
API_AnalyticalRigidityType | rzType |
Rotation type in Z direction. | |
double | rzValue |
Rotation value in Z direction in case of Custom type. | |
Contains the Structural Analytical Model Analytical Support values.