Archicad 27 C++ API
Loading...
Searching...
No Matches
API_AttributeFolderPickerParams Struct Reference

Describes the type and the push check for creating an attribute folder picker in ACAPI_Attribute_CreateAttributeFolderPicker. More...

#include <APIdefs_Interface.h>

Public Types

enum class  PushCheckAppearance { ArrowIconAndText , ArrowOnly }
 

Public Attributes

API_UserControlType type
 Requested type of the user control.
 
short dialogID = 0
 Id of the dialog of picker.
 
short itemID = 0
 Id of the attribute picker control.
 
PushCheckAppearance pushCheckAppearance
 Defines whether the push check item should contain only an arrow icon pointing to right (PushCheckAppearance::ArrowOnly), or an icon and a text part also ( PushCheckAppearance::ArrowIconAndText).
 

Detailed Description

Describes the type and the push check for creating an attribute folder picker in ACAPI_Attribute_CreateAttributeFolderPicker.

Since
Archicad 26