Archicad 27 C++ API
Loading...
Searching...
No Matches
API_AttributePickerParams Class Reference

Describes the type and the push check for creating an attribute picker in ACAPI_Dialog_CreateAttributePicker. More...

#include <APIdefs_Interface.h>

Public Types

enum class  PushCheckAppearance { ArrowIconAndText , ArrowOnly }
 Type of the push check item apperance in the button.
 
enum class  EmptySelectionBehaviour { SelectFirst , SelectNothing }
 
enum class  LockedLayersStatus { Disabled , Enabled }
 

Public Attributes

API_UserControlType type
 Requested type of the user control.
 
short dialogID = 0
 Id of the dialog of picker.
 
short itemID = 0
 Id of the push check of picker.
 
PushCheckAppearance pushCheckAppearance
 Defines whether the push check item should contain only an arrow icon pointing to right (PushCheckAppearance::ArrowOnly), or an icon and a text part also ( PushCheckAppearance::ArrowIconAndText).
 
EmptySelectionBehaviour emptySelectionBehaviour
 Tells what should happen with the selection during opening the popup, when the selected attribute index is not in the usable attribute set. Either the first attribute should be selected (EmptySelectionBehaviour::SelectFirst) or nothing should be selected in the appearing popup ( EmptySelectionBehaviour::SelectNothing).
 
LockedLayersStatus lockedLayersStatus
 Layer specific data that controls the appearance of locked layers in the Layer Picker. The value LockedLayersStatus::Disabled tells that locked layers are gray and unselectable. The default value of this field is LockedLayersStatus::Enabled.
 

Detailed Description

Describes the type and the push check for creating an attribute picker in ACAPI_Dialog_CreateAttributePicker.

Since
Archicad 26

Member Data Documentation

◆ type

API_AttributePickerParams::type

Requested type of the user control.

Remarks
Supported types in version 26 and later:
  • APIUserControlType_Layer
  • APIUserControlType_BuildingMaterial
  • APIUserControlType_WallComposites
  • APIUserControlType_SlabComposites
  • APIUserControlType_RoofComposites
  • APIUserControlType_ShellComposites
  • APIUserControlType_OnlyCompFill
  • APIUserControlType_AllProfile
  • APIUserControlType_WallProfile
  • APIUserControlType_BeamProfile
  • APIUserControlType_ColumnProfile
  • APIUserControlType_HandrailProfile
  • APIUserControlType_OtherGDLObjectProfile
  • APIUserControlType_Material
  • APIUserControlType_MaterialWithGeneral
Supported types in version 27 and later:
  • APIUserControlType_PolyFill
  • APIUserControlType_WallFill
  • APIUserControlType_WallCompFill
  • APIUserControlType_AllFillGradNoComp
  • APIUserControlType_CoverFill
  • APIUserControlType_PolyFillWithGradient
  • APIUserControlType_DashedLine
  • APIUserControlType_SymbolLine