Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Beam_Hole Struct Reference

Describes a beam hole. More...

#include <APIdefs_Elements.h>

Public Attributes

API_BHoleTypeID holeType
 Type of the hole (rectangular / circular).
 
bool holeContureOn
 Show the hole's contour in 2D?
 
Int32 holeID
 ID of the hole, unique in the beam.
 
double centerx
 The 'x' location of the hole's center relative to the beginning coordinate of the beam.
 
double centerz
 The 'z' location of the hole's center relative to the top of the beam.
 
double width
 The width of the hole.
 
double height
 The height of the hole (effective only for the rectangular type).
 

Detailed Description

Describes a beam hole.