Archicad 27 C++ API
Loading...
Searching...
No Matches
API_BeamQuantity Struct Reference

Describes the different calculated values for beams. More...

#include <APIdefs_Elements.h>

Public Attributes

double area
 area of the beam
 
double rightLength
 length of the beam on the right side of the reference line
 
double leftLength
 length of the beam on the left side of the reference line
 
double bottomSurface
 surface of the bottom of the beam
 
double topSurface
 surface of the top of the beam
 
double edgeSurfaceLeft
 surface of the beam on the left side of the reference line
 
double edgeSurfaceRight
 surface of the beam on the right side of the reference line
 
double edgeSurface
 surface of both ends of the beam
 
double holesSurface
 total surface of holes in the beam
 
double holesEdgeSurface
 total surface of hole edges in the beam
 
Int32 holesNumber
 number of holes in the beam
 
double crossSectionAreaCutBegin
 area of the beams begin cross section
 
double crossSectionAreaCutEnd
 area of the beams end cross section
 
double volume
 volume of the beam
 
double volume_cond
 conditional volume of the beam
 
double holesVolume
 total volume of holes in the beam
 

Detailed Description

Describes the different calculated values for beams.

Remarks
See also the beam parameters for listing in Appendix A of the GDL Reference manual.