Archicad 27 C++ API
Loading...
Searching...
No Matches
API_BeamSegmentQuantity Struct Reference

Describes the different calculated values for beam segments. More...

#include <APIdefs_Elements.h>

Public Attributes

double endSurface
 surface of the ends of the beam segment
 
double leftSurface
 surface of the left side of the beam segment
 
double rightSurface
 surface of the right side of the beam segment
 
double bottomSurface
 surface of the bottom of the beam segment
 
double topSurface
 surface of the top of the beam segment
 
double length
 length of the beam segment
 
double leftLength
 length of the beam segment on the left side
 
double rightLength
 length of the beam segment on the right side
 
double crossSectionAreaCutBegin
 area of the beam segment cut section at the beginning of the segment
 
double crossSectionAreaCutEnd
 area of the beam segment cut section at the end of the segment
 
double volume
 volume of the beam segment
 
Int32 holesNumber
 total number of holes in the beam segment
 
double holesSurface
 total surface of holes in the beam segment
 
double holesEdgeSurface
 total surface of hole edges in the beam segment
 
double holesVolume
 total volume of holes in the beam segment
 

Detailed Description

Describes the different calculated values for beam segments.