Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CWAccessoryType Struct Reference

Represents a curtain wall accessory element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
short pen
 For internal use.
 
API_CWAccessoryCategoryID category
 Category of the accessory. See API_CWAccessoryCategoryID.
 
API_Guid owner
 Owner Curtain Wall.
 
API_Guid symbolID
 Object identifier.
 
bool hasSymbol
 In normal case it is always true.
 
bool flipped
 Curtain Wall Accessory is flipped?
 
Int32 libInd
 Library Part index.
 
API_Guid refFrame
 Accessory is always joins to a frame. This is the reference frame.
 

Detailed Description

Represents a curtain wall accessory element.

Remarks
The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.