Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CWJunctionType Struct Reference

Represents a curtain wall junction element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
short pen
 For internal use.
 
API_CWJunctionCategoryID category
 Category of the junction. See API_CWJunctionCategoryID.
 
API_Guid owner
 Owner Curtain Wall.
 
API_Guid symbolID
 Object identifier. (junctions are always GDL based)
 
bool hasSymbol
 In normal case it is always true.
 
bool flipped
 True, if the frame is flipped.
 
UInt32 clampFramesNum
 Number of clamping frames.
 
UInt32 clampFrameOrientsNum
 In normal case it is equal to clampFramesNum.
 
UInt32 clampPanelsNum
 Number of clamping panels.
 
Int32 libInd
 Library Part index if the junction is GDL-based.
 

Detailed Description

Represents a curtain wall junction element.

Remarks
The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme. API_GridElemID is a typedef for UInt64.