Archicad 28 C++ API
|
Represents a curtain wall segment cell. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_CWCellCrossingFrameTypeID | crossingFrameType |
Describes the type of the crossing frame in the cell. | |
UInt32 | leftPanelID |
Class index of the panel left of the cell. | |
UInt32 | rightPanelID |
Class index of the panel right of the cell. | |
UInt32 | leftFrameID |
Class index of the frame left of the cell. | |
UInt32 | bottomFrameID |
Class index of the frame under the cell. | |
UInt32 | crossingFrameID |
Class index of the frame crossing the cell. | |
Represents a curtain wall segment cell.
API_CWSegmentPatternCellData::crossingFrameType |
Describes the type of the crossing frame in the cell.
Type | Meaning |
---|---|
APICWCFT_NoCrossingFrame | The cell does not have a crossing frame. |
APICWCFT_FromBottomLeftToTopRight | The cell has a crossing frame from its bottom left to its top right. |
APICWCFT_FromTopLeftToBottomRight | The cell has a crossing frame from its top left to its bottom right. |