Archicad 28 C++ API
|
Represents the horizontal (primary) or vertical (secondary) pattern of a Curtain Wall segment. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_CWSegmentPatternLogicID | logic |
Describes how the pattern is stretched in segments. | |
API_CWSegmentGridOrigPosTypeID | gridOriginType |
Describes how the pattern is aligned in segments. See available value in the documentation of API_CWSegmentGridOrigPosTypeID enum. | |
UInt32 | nPattern |
Amount of columns/rows in the pattern. | |
double * | pattern |
The distances of each columns/rows. | |
UInt32 * | flexibleIDs |
The indices of columns/rows that can be stretched. Only used in case of APICWSePL_BestDivision or APICWSePL_NumberOfDivisions logic. | |
UInt32 | nFlexibleIDs |
Amount of stretchable columns/rows. Only used in case of APICWSePL_BestDivision or APICWSePL_NumberOfDivisions logic. | |
UInt32 | nDivisions |
Amount of divisions. Only used in case of APICWSePL_NumberOfDivisions logic. | |
UInt32 | infillPanelID |
Class index of the panel, that fills the end of an incomplete pattern. Use APICWInfillWithPartial to fill with partial pattern. Only used in case of APICWSePL_FixedSizes logic. | |
UInt32 | endWithID |
The index of the ending panel. | |
Represents the horizontal (primary) or vertical (secondary) pattern of a Curtain Wall segment.
API_CWSegmentPatternData::logic |
Describes how the pattern is stretched in segments.
Type | Meaning |
---|---|
APICWSePL_FixedSizes | The length of the pattern is given explicitly. This may result in incomplete patterns. |
APICWSePL_BestDivision | The length of the pattern is stretched, so that the least amount of stretching is done. |
APICWSePL_NumberOfDivisions | The length of the pattern is stretched, so that exactly nDivisions amount of patterns are placed. |