Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CollisionDetectionSettings Struct Reference

Collision detection settings used by ACAPI_Element_GetCollisions. More...

#include <APIdefs_Goodies.h>

Public Attributes

double volumeTolerance
 Intersection body volume greater then this value will be considered as a collision.
 
bool performSurfaceCheck
 Enables surface collision check. If disabled the surfaceTolerance value will be ignored.
 
bool filler [7]
 
double surfaceTolerance
 Intersection body surface area greater then this value will be considered as a collision.
 

Detailed Description

Collision detection settings used by ACAPI_Element_GetCollisions.