Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CollisionElem Struct Reference

A container for storing a collision element created by ACAPI_Element_GetCollisions. More...

#include <APIdefs_Goodies.h>

Public Attributes

API_Guid collidedElemGuid
 The GUID of the collided element.
 
bool hasBodyCollision
 The element has body collision.
 
bool hasClearenceCollision
 The element has clearance collision.
 
bool filler [6]
 

Detailed Description

A container for storing a collision element created by ACAPI_Element_GetCollisions.