Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ColumnQuantity Struct Reference

Describes the different calculated values for columns. More...

#include <APIdefs_Elements.h>

Public Attributes

double coreSurface
 surface of the column core
 
double veneSurface
 surface of the column veneer
 
double coreVolume
 volume of the column core
 
double veneVolume
 volume of the column veneer
 
double minHeight
 minimum height of the column
 
double maxHeight
 maximum height of the column
 
double perimeter
 perimeter of the column
 
double area
 area of the column
 
double coreGrossSurf
 gross surface of the core
 
double veneGrossSurf
 gross surface of the veneer
 
double crossSectionAreaCutBegin
 area of the columns begin cross section
 
double crossSectionAreaCutEnd
 area of the columns end cross section
 
double coreGrossVolume
 gross volume of the core
 
double veneGrossVolume
 gross volume of the veneer
 
double coreTopSurf
 surface of the core top
 
double coreBotSurf
 surface of the core bottom
 
double veneTopSurf
 surface of the veneer top
 
double veneBotSurf
 surface of the veneer bottom
 
double coreGrossTopBotSurf
 gross surface of the core top and bottom
 
double veneGrossTopBotSurf
 gross surface of the veneer top and bottom
 

Detailed Description

Describes the different calculated values for columns.

Remarks
See also the column description in Appendix A of the GDL Reference manual.