Archicad 27 C++ API
Loading...
Searching...
No Matches
API_DescriptorRefType Struct Reference

The descriptor reference record. More...

#include <APIdefs_Elements.h>

Public Attributes

Int32 libIndex
 Index of the library part, place of the descriptor declaring.
 
Int32 setIndex
 Index of the listing database set, if status equals APIDBRef_Normal.
 
Int32 index
 This member depends on the status field. If status equals APIDBRef _Normal, then index is index of the descriptor in the set, if status equals APIDBRef _Local, then index is index of the descriptor in the library part.
 
Int32 status
 This member is status of descriptor(APIDBRef__Normal, APIDBRef__Local, APIDBRef_Deleted).
 

Detailed Description

The descriptor reference record.

Remarks
This structure is used when you want to get the descriptors of an element. These descriptors are in the property objects of the element. See the ACAPI_Element_GetDescriptors function.