Archicad 27 C++ API
Loading...
Searching...
No Matches
API_DescriptorType Struct Reference

Description of a descriptor. More...

#include <APIdefs_ListData.h>

Public Attributes

API_ListData_Head head
 Contains the header information, including type, set index and index.
 
char code [API_DBCodeLen]
 Descriptor code.
 
char keycode [API_DBCodeLen]
 Descriptor key code.
 
char dbSetName [API_DBCodeLen]
 Descriptor database set name.
 
char ** name
 name of the descriptor
 

Detailed Description

Description of a descriptor.

Remarks
This stucture is used when you get or search a descriptor in the listing database. See the ACAPI_OldListing_Get, ACAPI_OldListing_GetLocal and ACAPI_OldListing_Search functions. Remember to dispose of the name handle when you are done.