Archicad 27 C++ API
Loading...
Searching...
No Matches
API_DrawingTitle Struct Reference

Specifies the drawing's title object. More...

#include <APIdefs_Elements.h>

Public Attributes

Int32 libInd
 Library part index of the title.
 
API_TitlePreviewModes previewMode
 Show the title preview with or without the drawing itself (see API_TitlePreviewModes).
 
bool useUniformTextFormat
 Use the fonts and style set on the title tabpage.
 
short font
 Title common text font ID.
 
unsigned short faceBits
 Plain, bold, italic, underline.
 
short textPen
 Title common text pen.
 
double textSize
 Title text size.
 
bool flipped
 The title object is flipped.
 
bool useUniformSymbolPens
 Use the pens set on the title tabpage.
 
short pen
 Title common pen.
 
API_Guid guid
 Guid of title element (the placed object).
 

Detailed Description

Specifies the drawing's title object.

Remarks
Drawing titles are now object based elements from Archicad 10.