Archicad 27 C++ API
Loading...
Searching...
No Matches
API_EdgeType Struct Reference

Representation of a 3D edge. More...

#include <APIdefs_3D.h>

Public Attributes

API_3D_Head head
 Header information of this component. This specifies the type and database index.
 
Int32 status
 Information about the edge properties.
 
short color
 Refers to the color of the edge.
 
Int32 vert1
 Vertex index of one edge endpoint.
 
Int32 vert2
 Vertex index of the other edge endpoint.
 
Int32 pgon1
 Index of one of the neighbouring polygons.
 
Int32 pgon2
 Index of the other neighbouring polygon.
 

Detailed Description

Representation of a 3D edge.

Remarks
Polygons are lists of edges with orientation, including the indices of the edges. One edge may belong to 0 to 2 polygons. Its indices are included in pgon1, pgon2. In the case of a side or single line, the missing polygon is signed with a -1 index. An edge has two endpoints, indexed by vert1, and vert2. Note that in the case of closed bodies, the polygon's orientation is correct if the edge has different prefixes in the edge list of the two polygons. Accessing edges are based on a body. First, you must get a body by ACAPI_ModelAccess_GetComponent, and then its components are obtainable.