Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ElemInfo3D Struct Reference

3D data of an element. More...

#include <APIdefs_Elements.h>

Public Attributes

UInt32 fElemIdx
 It is equal to the incoming element index.
 
UInt32 fBodyIdx
 It is always zero.
 
UInt32 lElemIdx
 It is equal to the incoming element index.
 
UInt32 lBodyIdx
 Index of the last body which belongs to the element. (not flat list)
 
Int32 fbody
 Index of the first body which belongs to the element.
 
Int32 lbody
 Index of the last body which belongs to the element.
 
Int32 flight
 Index of the first light source which belongs to the element.
 
Int32 llight
 Index of the last light source which belongs to the element.
 
API_Box3D bounds
 The 3D bounding box of the element.
 

Detailed Description

3D data of an element.

Remarks
Use the ACAPI_ModelAccess_Get3DInfo function to get the 3D representation of a construction element. Once an element is converted to 3D, it will have the following components:
  • model information based on BODYs,
  • lighting model based on LIGHTs; if lights are defined from the 3D GDL script,
  • materials; either from the global attribute pool, or defined from the 3D GDL script. All of the data can be accessed through the API_Component3D structure.