Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ElemURLRef Struct Reference

URL reference to be stored into elements. More...

#include <APIdefs_Database.h>

Public Attributes

char urlLink [512]
 The URL link (e.g., "http://www.graphisoft.com")
 
char description [256]
 Description for the URL above (e.g., "GRAPHISOFT Home Page").
 
char filler [256]
 

Detailed Description

URL reference to be stored into elements.

Remarks
This structure is used for storing URL references into Archicad database elements. The element URL data can be accessed with the ACAPI_Element_GetElementURLRef and ACAPI_Element_SetElementURLRef database functions.