Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ExtendedPenType Struct Reference

Describes the optionally overridden pen used for hatches. More...

#include <APIdefs_Elements.h>

Public Member Functions

void Set (short pen1, short pen2)
 Sets both the normal and the overridden pen color index.
 
bool IsOverriden () const
 Tells whether the pen index is overridden.
 
short GetEffectiveColorIndex () const
 Returns the effective pen color index.
 

Public Attributes

short penIndex
 The pen color index if not overridden; the original pen index.
 
short colorOverridePenIndex
 The pen color index if overridden.
 

Detailed Description

Describes the optionally overridden pen used for hatches.

Member Function Documentation

◆ GetEffectiveColorIndex()

short API_ExtendedPenType::GetEffectiveColorIndex ( ) const
inline

Returns the effective pen color index.

Returns
Pen color index.

◆ IsOverriden()

bool API_ExtendedPenType::IsOverriden ( ) const
inline

Tells whether the pen index is overridden.

Returns
True if it is overridden.

◆ Set()

void API_ExtendedPenType::Set ( short  pen1,
short  pen2 
)
inline

Sets both the normal and the overridden pen color index.

Parameters
pen1Pen index.
pen2Color override pen index.