Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ExternalElemType Struct Reference

A struct containing the header and data of an external element type (see API_AnalyticalLinkType). More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header. The typeID should be API_ExternalElemType.
 
char externalElemData [API_ExternalElemDataSize]
 Serialized data identifying the element.
 

Detailed Description

A struct containing the header and data of an external element type (see API_AnalyticalLinkType).

Since
Archicad 26
Remarks
In version 26 the Analytical element types were replaced by the externalElem member. The former structures (e.g. API_AnalyticalLinkType) can be obtained by the appropriate functions (e.g. ACAPI_Analytical_GetLinkFromElement).