Archicad 27 C++ API
Loading...
Searching...
No Matches
API_GridMeshLine Struct Reference

Describes a grid line of the mesh. More...

#include <APIdefs_Base.h>

Public Attributes

API_GridMeshHead head
 Identifies the mesh element.
 
API_GridElemID begID
 The identifier of begpoint vertices.
 
API_GridElemID endID
 The identifier of endpoint vertices.
 
UInt32 userData
 Custom value assigned to this mesh line.
 
bool mainDir
 If false then secondary direction.
 

Detailed Description

Describes a grid line of the mesh.