Archicad 28 C++ API
Loading...
Searching...
No Matches
API_HourlyProfile Struct Reference

Describes coverage of an hour of an Operation Profile. More...

#include <APIdefs_Attributes.h>

Public Attributes

GS::uchar_t name [API_UniLongNameLen]
 The name of the hourly profile.
 
double minTemp
 Hourly desired minimum temperature.
 
bool minTempDef
 Minimum temperature define.
 
double maxTemp
 Hourly desired maximum temperature.
 
bool maxTempDef
 Maximum temperature define.
 
double occupancyCount
 Hourly occupancy count.
 
double lightGain
 Hourly light gain.
 
double equipmentGain
 Hourly equipment gain.
 

Detailed Description

Describes coverage of an hour of an Operation Profile.