Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCAttribute Struct Reference

IFC attribute structure. More...

#include <APIdefs_Properties.h>

Public Attributes

GS::UniString attributeName
 Name of the attribute.
 
GS::UniString attributeType
 IFC type of the attribute in string format.
 
GS::UniString attributeValue
 Value of the attribute in string format.
 
bool hasValue
 In case of optional attributes it says if the attribute is set and checked on the user interface.
 
bool readOnly
 Whether the attribute is read-only.
 

Detailed Description

IFC attribute structure.

Remarks
This structure contains the data of an IFC attribute. Attributes of an IFC type are a fix list, so this structure can be used to get and modify attributes only. readOnly flag of an attribute cannot be changed, it is informational only.