Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCClassification Struct Reference

IFC classification structure. More...

#include <APIdefs_Properties.h>

Public Attributes

GS::Optional< GS::UniString > source
 source of classification
 
GS::Optional< GS::UniString > edition
 edition of classification
 
GS::Optional< GS::UniString > editionDate
 the date on which the edition of the classification used became valid
 
GS::UniString name
 name of classification
 
GS::Optional< GS::UniString > description
 description of the classification
 
GS::Optional< GS::UniString > location
 resource identifier or locator of the classification
 

Detailed Description

IFC classification structure.

Remarks
This structure contains the data of an IfcClassification.