Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCPropertyHead Struct Reference

IFC property header structure. More...

#include <APIdefs_Properties.h>

Public Attributes

GS::UniString propertySetName
 Name of the containing propertyset.
 
GS::UniString propertyName
 Name of the property.
 
GS::UniString propertyDescription
 Description of the property.
 
API_IFCPropertyType propertyType
 Type of the IFC property.
 
bool readOnly
 Indicate that the property is writeable or readOnly.
 

Detailed Description

IFC property header structure.

Remarks
This structure holds common information of all IFC Property types. propertyName and propertySetName shall not be empty strings. propertyName and propertySetName pairs of an element are unique.

Member Data Documentation

◆ propertyType

API_IFCPropertyHead::propertyType

Type of the IFC property.

API_IFCPropertyType Meaning
API_IFCPropertySingleValueType Property with a single value
API_IFCPropertyListValueType Property with a list of values
API_IFCPropertyBoundedValueType Property with a lowerbound and upperbound value
API_IFCPropertyEnumeratedValueType Property with a list of possible and selected values
API_IFCPropertyTableValueType Property with a list of value pairs