Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LayoutsPrefs Struct Reference

The representation of the Layouts page of the Project Preferences. More...

#include <APIdefs_Environment.h>

Public Attributes

API_RGBColor masterColor
 Color of master items on the layout.
 
bool useOwnMasterColor
 Use master items' own color.
 
bool adjustDrawingFrameToViewZoom
 When placing model views onto layouts, adjust each drawing frame to show only zoomed area of model view.
 
char filler [6]
 Reserved for later use.
 

Detailed Description

The representation of the Layouts page of the Project Preferences.

Remarks
This structure is used by the ACAPI_ProjectSetting_GetPreferences function to get the settings of the Layouts preferences page.