Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LegacyPrefs Struct Reference

The representation of the Preferences / Legacy tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

Int32 coluConnPriority
 The priority factor for column intersection.
 
API_AttributeIndex aboveLineType
 Line type index to be used for displaying construction elements above their home story.
 
API_AttributeIndex belowLineType
 Line type index to be used for displaying construction elements below their home story.
 
API_RoofContourDisplay roofContourDisplay
 Display the roof with all visible contours (APIRoofDisplay_AllVisibleContours), or the old way (APIRoofDisplay_OnlyTheTopSurfaceOldWay). Possible values: API_RoofContourDisplay APIRoofDisplay_AllVisibleContours APIRoofDisplay_OnlyTheTopSurfaceOldWay.
 
bool useLegacyIntersections
 Use legacy intersection and Surface methods for model elements.
 
bool hideZonesOnSections
 Hide zones on sections.
 

Detailed Description

The representation of the Preferences / Legacy tab page.

Remarks
This structure is used by the ACAPI_ProjectSetting_GetPreferences function to get the legacy preferences page. The aboveLineType and belowLineType parameters are are only effective on Library Parts if the "Use Symbol Linetypes" checkbox in their Settings dialog boxes is switched off. They have no effect on Ghost Story elements.