Archicad 28 C++ API
|
Library part's details of window and door. Used in API_LibPartDetails. More...
#include <APIdefs_LibraryParts.h>
Public Attributes | |
char | mirThickExpr [512] |
Window/door draw mirror thickness expression. | |
char | wallInsetExpr [512] |
Window/door parapet wall inset expression. | |
char | leftFramExpr [512] |
Window/door left frame expression. | |
char | righFramExpr [512] |
Window/door right frame expression. | |
char | topFramExpr [512] |
Window/door top frame expression. | |
char | botFramExpr [512] |
Window/door bottom frame expression. | |
float | mirThick |
Window/door draw mirror thickness if not expression. | |
float | wallInset |
Window/door parapet wall inset if not expression. | |
float | leftFram |
Window/door left frame if not expression. | |
float | righFram |
Window/door right frame if not expression. | |
float | topFram |
Window/door top frame if not expression. | |
float | botFram |
Window/door bottom frame if not expression. | |
char | orientation |
Defines the way the opening's orientation is displayed: | |
bool | contours_3D |
3D image is framed (wind/door). | |
bool | uiTabDefault |
Open the dialog with the User Interface tab page as the default. | |
bool | uiUseHierarchicalPages |
Use the new hierarchical UI page system in object settings dialog. | |
bool | runVLScriptOnlyOnce |
Run the parameter script of the library only once (until any change happens). | |
bool | enable2DScriptDrawingOrder |
Drawing order follows order of commands in 2D Script. | |
char | defaultLabel [32] |
Default position label. | |
char | mirroredLabel [32] |
Mirrored position label. | |
Library part's details of window and door. Used in API_LibPartDetails.
API_LibPartDoorWindowDetails::orientation |
Defines the way the opening's orientation is displayed:
Value | Meaning |
---|---|
API_Orient_Default | Display Door/Window opening orientation as a standard default setting |
API_Orient_Reverse | Display Door/Window opening orientation in reverse as a standard default setting |
API_Orient_Custom | Use customized display of Door/Window opening orientation |