Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LibPartDetails Union Reference

Detail parameters of a Library Part. More...

#include <APIdefs_LibraryParts.h>

Public Attributes

API_LibPartObjectDetails object
 Library part's details of an object.
 
API_LibPartObjectDetails light
 Library part's details of a light.
 
API_LibPartObjectDetails label
 Library part's details of a label.
 
API_LibPartObjectDetails zone
 Library part's details of a zone.
 
API_LibPartDoorWindowDetails wind
 Library part's details of a window.
 
API_LibPartDoorWindowDetails door
 Library part's details of a door.
 

Detailed Description

Detail parameters of a Library Part.

Remarks
This structure contains the detail parameters of the library part. These parameters can be edited in Archicad by clicking the Details button on the parameter list editor dialog box. Note, that the parameters depend on the type of the Library Part. These parameters are coded in the parameter section (API_SectParamDef) of the Library Part. Refer to the ACAPI_LibraryPart_GetDetails and ACAPI_LibraryPart_SetDetails_ParamDef functions to get or modify such parameters of a Library Part. In Archicad 10 the contours_2D field has been removed from the structure.