Library part's details of object, light, label and zone. Used in API_LibPartDetails.
More...
#include <APIdefs_LibraryParts.h>
|
bool | fixSize |
| Store fix values rather than the ratio of current/default A/B sizes.
|
|
bool | autoHotspot |
| Place hotspots on the bounding box.
|
|
bool | uiTabDefault |
| Open the dialog with the User Interface tab page as the default.
|
|
bool | sizeTo2D |
| Adjust parameters A and B to the bounding box of the 2D symbol.
|
|
bool | uiUseHierarchicalPages |
| Use the new hierarchycal UI page system in object settings dialog.
|
|
bool | runVLScriptOnlyOnce |
| Run the parameter script of the library only once.
|
|
bool | enableHideFixNamedParams |
| Enable or disable fixed name library part parameters.
|
|
bool | enable2DScriptDrawingOrder |
| Drawing order follows order of commands in 2D Script.
|
|
Library part's details of object, light, label and zone. Used in API_LibPartDetails.