Archicad 27 C++ API
Loading...
Searching...
No Matches
API_MeshQuantity Struct Reference

Describes the different calculated values for meshes. More...

#include <APIdefs_Elements.h>

Public Attributes

double bottomSurface
 bottom surface of the mesh
 
double topSurface
 top surface of the mesh
 
double edgeSurface
 surface of the edge of the mesh
 
double volume
 volume of the mesh
 
double perimeter
 perimeter of the mesh
 
double holesSurf
 total area of holes in the mesh
 
double holesPrm
 total perimeter of holes in the mesh
 
double projectedArea
 projected area of the mesh
 

Detailed Description

Describes the different calculated values for meshes.

Remarks
See also the mesh parameters for listing in Appendix A of the GDL Reference manual.