Returns the morph quantity values.
More...
#include <APIdefs_Elements.h>
|
double | surface |
| Net area of the body surface.
|
|
double | volume |
| Net volume of the body.
|
|
double | floorPlanArea |
| Net area of the floor plan projection.
|
|
double | floorPlanPerimeter |
| Perimeter of the floor plan projection.
|
|
double | baseLevel |
| Elevation.
|
|
double | baseHeight |
| The height range from the lowest point of inward-sloping faces to the highest point within the story height, relative to the story.
|
|
double | wholeHeight |
| Height of the morph.
|
|
UInt32 | nodesNr |
| Number of the nodes of the body.
|
|
UInt32 | edgesNr |
| Number of the edges of the body.
|
|
UInt32 | hiddenEdgesNr |
| Number of the hidden edges of the body.
|
|
UInt32 | softEdgesNr |
| Number of the soft edges of the body.
|
|
UInt32 | visibleEdgesNr |
| Number of the visible edges of the body.
|
|
UInt32 | facesNr |
| Number of the faces of the body.
|
|
Returns the morph quantity values.