Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Obsolete_ComponentRefType Struct Reference

The component reference record. More...

#include <APIdefs_Elements.h>

Public Attributes

Int32 libIndex
 Index of the library part where the component was declared.
 
Int32 setIndex
 Index of the listing database set, if status is equal to APIDBRef_Normal.
 
Int32 index
 This member depends on the status field. If status equals APIDBRef _Normal, then index is index of the component in the set, if status equals APIDBRef_Local, then index is index of the component in the library part.
 
Int32 status
 This member is status of component(APIDBRef__Normal, APIDBRef__Local, APIDBRef_Deleted).
 
double quantity
 Calculated quantity of component.
 

Detailed Description

The component reference record.

Remarks
This structure is obsolete. Use the new component API instead. This structure is used when you want to get the components of an element. These components are in the property objects of the element. See the ACAPI_Element_GetComponents_Obsolete function. This stucture is used when you get or search a component in the listing database. See the ACAPI_OldListing_Get, ACAPI_OldListing_GetLocal and ACAPI_OldListing_Search functions.