Archicad 27 C++ API
Loading...
Searching...
No Matches
API_OpeningExtrusionParameters Struct Reference

Opening extrusion parameters. More...

#include <APIdefs_Elements.h>

Public Attributes

API_OpeningBasePolygonTypeTypeID basePolygonType
 Type of base polygon.
 
double width
 Width of base polygon. Valid only if base polygon is rectangular or circular.
 
double height
 Height of base polygon. Valid only if base polygon is rectangular or circular.
 
API_OpeningConstraintTypeID constraint
 Extrusion limit type.
 
API_AnchorID anchor
 The anchor point of the opening.
 
double anchorAltitude
 Altitude of opening anchor. Valid only if constraint is forced horizontal or aligned.
 
API_OpeningLimitTypeTypeID limitType
 Extrusion limit type.
 
double extrusionStartOffset
 Offset from reference plane of the opening. Valid only if limitType is not infinite.
 
double finiteBodyLength
 Extrusion body length. Valid only if limitType is finite.
 
API_OpeningLinkedStatusTypeID linkedStatus
 Linked dimensions type. Valid only if base polygon is rectangular or circular.
 

Detailed Description

Opening extrusion parameters.