Archicad 28 C++ API
|
Represents an opening element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
API_Guid | owner |
Reference to the element the opening is associated to. (see API_Guid). | |
API_OpeningFloorPlanParameters | floorPlanParameters |
Floor plan parameters of the opening. | |
API_OpeningExtrusionGeometryData | extrusionGeometryData |
Geometry data of the opening extrusion. | |
Represents an opening element.