Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ParagraphType Struct Reference

Describes a paragraph of a text. More...

#include <APIdefs_Elements.h>

Public Attributes

Int32 from
 The beginning byte offset of the paragraph in the content.
 
Int32 range
 The range of the paragraph in byte offset.
 
API_JustID just
 Justification of the paragraph (see API_JustID).
 
double firstIndent
 First indent in mm.
 
double indent
 Indent in mm.
 
double rightIndent
 Right indent in mm.
 
double spacing
 Spacing factor between text lines (it should be between -10.0 and -1.0).
 
API_TabTypetab
 Tabulator(s) of a paragraph (see API_TabType).
 
API_RunTyperun
 Run(s) of a paragraph (see API_RunType).
 
Int32 * eolPos
 Line end positions in byte offset.
 
double width
 Width of the paragraph in mm (output only).
 
double height
 Height of the paragraph in mm (output only).
 

Detailed Description

Describes a paragraph of a text.

Remarks
From Archicad 9 you are able to create multistyle text or textual label. API_ParagraphType structure contains all related informations for a paragraph. By text or textual label element creating you can pass the content as a UniCode string (set charCode field of API_TextType structure to CC_UniCode and cast textContent field of API_ElementMemo to (unsigned short*)). In this case all offsets (from, range...) are character offset instead of byte offset. For more details examine Element Manager example project.