Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PersCamSetPars Struct Reference

Represents a perspective camera set. More...

#include <APIdefs_Elements.h>

Public Attributes

bool openedPath
 Open or closed animation path?
 
bool bezierPath
 Generate the in-between frames along polygonal or Bezier animation path?
 
bool smoothTarget
 Generate the in-between frames along a straight line or a smooth curve?
 
short pen
 Pen attribute index of the camera and the path.
 
Int32 inFrames
 Number of the in-between frames.
 
Int32 showFrom
 First camera index in slide.
 
Int32 showTo
 Last camera index in slide.
 

Detailed Description

Represents a perspective camera set.

Remarks
These fields correspond to the fields of the Path Options dialog.