Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PolygonExt Struct Reference

Representation of a 2D polygon and the 3D transformation plane. More...

#include <APIdefs_3D.h>

Public Attributes

API_Polygon polygon
 Representation of the two dimensional polygon.
 
API_ElementMemo polygonData
 Contains the geometry data of the polygon.
 
API_Plane3D plane
 Plane which transforms the points of the polygon into 3D coordinates.
 

Detailed Description

Representation of a 2D polygon and the 3D transformation plane.

Remarks
Refer to the API_Polygon, API_ElementMemo and API_Plane3D structures for more details.