Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PrimPLine Struct Reference

A primitive polyline. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Prim_Head head
 General primitive element header.
 
API_AttributeIndex ltypeInd
 Line type attribute index.
 
short determination
 Line category:
 
short drawSegmentMode
 Determine the draw segment mode of the polyline. 0 means draw segments one-by-one, 1 means draw segments continuously.
 
Int32 nCoords
 Number of vertices.
 
Int32 nArcs
 Number of arcs.
 
double penWeight
 Thickness of the polyline segments in mm.
 

Detailed Description

A primitive polyline.

Remarks
The actual coordinates of the polyline vertices are passed in the par1 parameter of the ShapePrimsProc function. The par3 parameter contains the polyline arcs.

Member Data Documentation

◆ determination

API_PrimPLine::determination

Line category:

Category Meaning
APILine_DetOrigin Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.
APILine_DetInnerLine A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.
APILine_DetContourLine Lines in the Cut line category will be affected if you have chosen the 'Bold Cut Line' setting in the Line Weight menu of Display Options.