Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PrimTri Struct Reference

A primitive triangle. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Prim_Head head
 General primitive element header.
 
API_AttributeIndex ltypeInd
 Line type attribute index.
 
bool solid
 Filled with solid color?
 
short determination
 Line category:
 
double penWeight
 Thickness of the triangle segments in mm.
 
API_Coord c [3]
 Triangle's vertices.
 

Detailed Description

A primitive triangle.

Member Data Documentation

◆ determination

API_PrimTri::determination

Line category:

Category Meaning
APILine_DetOrigin Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.
APILine_DetInnerLine A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.
APILine_DetContourLine Lines in the Cut line category will be affected if you have chosen the 'Bold Cut Line' setting in the Line Weight menu of Display Options.