Archicad 28 C++ API
|
Attribute representing the custom profiles for walls, beams, and columns. More...
#include <APIdefs_Attributes.h>
Public Attributes | |
API_Attr_Head | head |
The attribute header. | |
bool | wallType |
Profile available for walls. | |
bool | beamType |
Profile available for beams. | |
bool | coluType |
Profile available for columns. | |
bool | handrailType |
Profile available for handrails. | |
bool | otherGDLObjectType |
Profile available for other GDL based objects. | |
Attribute representing the custom profiles for walls, beams, and columns.
profile_vectorImageItems
field of the API_AttributeDefExt structure. This extended data holds simple 2D elements: hotspots, lines, arcs, hatches, splines, texts, and images in a serialized form. A simple example for creating and parsing a profile attribute can be found in the Attribute_Test example. The flags
in ProfileItem of ProfileFillData (the profile description) may have the following values: Value | Description |
---|---|
APISkin_HatchAngle | The fill direction is determined by the project origin (if not set), or the element's origin (if set). |
APISkin_Core | The skin's fill is part of the core. |
APISkin_Finish | The skin's fill is part of the finish. |
APISkin_HatchFit | The skin's fill is distorted to fit the skin's polygon. |