Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PropertyGroup Struct Reference

A structure representing a property group. More...

#include <APIdefs_Properties.h>

Public Attributes

API_PropertyGroupType groupType
 The type of this property group.
 
API_Guid guid
 The unique identifier of the property group.
 
GS::UniString name
 The name of the property group.
 
GS::UniString description
 The description of the property group.
 

Detailed Description

A structure representing a property group.

Member Data Documentation

◆ groupType

API_PropertyGroup::groupType

The type of this property group.

API_PropertyGroupType Meaning
API_PropertyStaticBuiltInGroupType All of the property definitions in this group are API_PropertyStaticBuiltInDefinitionType
API_PropertyDynamicBuiltInGroupType All of the property definitions in this group are API_PropertyDynamicBuiltInDefinitionType
API_PropertyCustomGroupType All of the property definitions in this group are API_PropertyCustomDefinitionType

◆ name

API_PropertyGroup::name

The name of the property group.

Remarks
This name should only be used for user defined property groups.