Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PropertyValue Struct Reference

A container for storing a property's value. More...

#include <APIdefs_Properties.h>

Public Attributes

API_SingleVariant singleVariant
 The value of the property if the definition's collectionType is API_PropertySingleCollectionType or API_PropertySingleChoiceEnumerationCollectionType. In case of enumeration, the keyVariant of the selected enum value is stored here (added in.
 
API_ListVariant listVariant
 The value of the property if the definition's collectionType is API_PropertyListCollectionType or API_PropertyMultipleChoiceEnumerationCollectionType. In case of enumeration, the keyVariant of the selected enum values are stored here (added in.
 
API_VariantStatus variantStatus
 The status of the property's currently valid value. If the status is not set to APIVariantStatusNormal, the property value is ignored.
 

Detailed Description

A container for storing a property's value.

Remarks
  You can easily convert the evaluated property value to display string with the ACAPI_Property_GetPropertyValueString function. In Archicad 25 the singleEnumVariant and multipleEnumVariant members were removed. In case of enumeration values the keyVariant of the selected enum value is stored in the singleVariant or listVariant member instead. If you need to, you can retrieve the displayVariant or nonLocalizedValue of the enumeration from the property definition's possibleEnumValues member based on the stored keyVariant.