Archicad 28 C++ API
Loading...
Searching...
No Matches
API_RVMChange Struct Reference

Represents a revision change. More...

#include <APIdefs_Database.h>

Public Attributes

GS::UniString id
 Unique ID of the Change.
 
GS::UniString description
 Short description of the Change.
 
GSTime lastModifiedTime
 Last modified time of the Change.
 
GS::UniString modifiedByUser
 Teamwork user identifier (full name) who last modified the Change.
 
bool issued
 Change in a document revision is in an issue or not.
 
bool archived
 Change is archived or active.
 
GS::HashTable< API_Guid, GS::UniString > customData
 Contains the custom data fields. The custom scheme GUID-value pairs are stored in a GS::HashTable.
 

Detailed Description

Represents a revision change.

Remarks
You are able to get all changes via ACAPI_Revision_GetRVMChanges function, and get the custom scheme of changes via ACAPI_Revision_GetRVMChangeCustomScheme function.