Archicad 27 C++ API
Loading...
Searching...
No Matches
Revision Management

The API of the document revision and issue management system. Differs from the Issue Management system, which deals with issues regarding the project and the model. More...

Classes

struct  API_RVMChange
 Represents a revision change. More...
 
struct  API_RVMIssue
 Represents an Issue. More...
 
struct  API_RVMLayoutInfo
 Represents layout meta data in API_RVMDocumentRevision. More...
 
struct  API_RVMDocumentRevision
 Represents a Document Revision. More...
 

Enumerations

enum  API_RVMDocumentRevisionStatusID { API_RVMDocumentRevisionStatusActual = 0 , API_RVMDocumentRevisionStatusIssued = 1 }
 Status of the document revision. More...
 

Functions

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChanges (GS::Array< API_RVMChange > *api_changes)
 Retrieves all changes.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChangeCustomScheme (GS::HashTable< API_Guid, GS::UniString > *customScheme)
 Retrieves change custom scheme.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMIssues (GS::Array< API_RVMIssue > *api_issues)
 Retrieves all issues.
 
GSErrCode __ACENV_CALL ACAPI_Revision_ChangeRVMIssue (API_RVMIssue *api_issue)
 Modify an RVM issue.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMIssueCustomScheme (GS::HashTable< API_Guid, GS::UniString > *customScheme)
 Retrieves issue custom scheme.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMDocumentRevisions (GS::Array< API_RVMDocumentRevision > *api_revisions)
 Retrieves all document revisions.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChangesFromChangeIds (const GS::Array< GS::UniString > *changeIds, GS::Array< API_RVMChange > *api_changes)
 Retrieves all changes those given by unique change IDs.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMLayoutCurrentRevisionChanges (const API_DatabaseUnId *inUnId, GS::Array< API_RVMChange > *api_changes)
 Retrieves all changes belong to the last revision of the given layout.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMIssueDocumentRevisions (const API_Guid *issueGuid, GS::Array< API_RVMDocumentRevision > *api_revisions)
 Retrieves all document revisions belong to the given issue.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMDocumentRevisionChanges (const API_Guid *revisionGuid, GS::Array< API_RVMChange > *api_changes)
 Retrieves all changes belong to the given document revision.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMElemChangeIds (const API_Guid *elemGuid, GS::Array< GS::UniString > *api_changeIds)
 Retrieves the change IDs of the given elem identified by GUID.
 
GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChangeFirstIssue (const GS::UniString *api_changeId, API_RVMIssue *api_firstIssue)
 Retrieves the issue in which the given change is issued at first.
 

Detailed Description

The API of the document revision and issue management system. Differs from the Issue Management system, which deals with issues regarding the project and the model.

Enumeration Type Documentation

◆ API_RVMDocumentRevisionStatusID

Status of the document revision.

Remarks
This type specifies in API_RVMDocumentRevision whether document revision is issued or opened.

Function Documentation

◆ ACAPI_Revision_ChangeRVMIssue()

GSErrCode __ACENV_CALL ACAPI_Revision_ChangeRVMIssue ( API_RVMIssue api_issue)

Modify an RVM issue.

Parameters
api_issue[in] The RVM issue to change.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - api_issue is nullptr.
  • APIERR_BADNAME - the ID in api_issue is not valid.
  • APIERR_NOACCESSRIGHT - api_issue has already been issued.
  • APIERR_GENERAL - Couldn't get the issues.
Remarks
This function modifies the short description, the ID, or the custom data of the given issue. This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

◆ ACAPI_Revision_GetRVMChangeCustomScheme()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChangeCustomScheme ( GS::HashTable< API_Guid, GS::UniString > *  customScheme)

Retrieves change custom scheme.

Parameters
customSchemeContains API_Guid (unique identifier of a custom field), GS::UniString (name of a custom field) pairs.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - customScheme is nullptr.
  • APIERR_GENERAL - Couldn't get the customScheme.
Remarks
This function retrieves custom fields of the API_RVMChange s.

◆ ACAPI_Revision_GetRVMChangeFirstIssue()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChangeFirstIssue ( const GS::UniString *  api_changeId,
API_RVMIssue api_firstIssue 
)

Retrieves the issue in which the given change is issued at first.

Parameters
api_changeIdID of the change.
api_firstIssueThe first issue in which the given change is issued.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - api_changeId or api_firstIssue is nullptr.
  • APIERR_BADID - api_changeId does not identify a valid change.
  • APIERR_GENERAL - Couldn't get the first issue.
Remarks
You are able to get the first issue that the given GS::UniString identified change is issued in.

◆ ACAPI_Revision_GetRVMChanges()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChanges ( GS::Array< API_RVMChange > *  api_changes)

Retrieves all changes.

Parameters
api_changesThe array of the changes.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - api_changes is nullptr.
  • APIERR_GENERAL - Couldn't get the changes.
Remarks
This function retrieves all changes.

◆ ACAPI_Revision_GetRVMChangesFromChangeIds()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMChangesFromChangeIds ( const GS::Array< GS::UniString > *  changeIds,
GS::Array< API_RVMChange > *  api_changes 
)

Retrieves all changes those given by unique change IDs.

Parameters
changeIdsThe array of the change IDs.
api_changesThe array of the changes.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - changeIds or api_changes is nullptr.
  • APIERR_GENERAL - Couldn't get the changes.
Remarks
If only unique change IDs are owned, API_RVMChange s can be retrieved by this function.

◆ ACAPI_Revision_GetRVMDocumentRevisionChanges()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMDocumentRevisionChanges ( const API_Guid revisionGuid,
GS::Array< API_RVMChange > *  api_changes 
)

Retrieves all changes belong to the given document revision.

Parameters
revisionGuidGUID of the document revision.
api_changesThe array of the changes.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - revisionGuid or api_changes is nullptr.
  • APIERR_BADID - revisionGuid does not identify a valid document revision.
  • APIERR_GENERAL - Couldn't get the changes.
Remarks
You are able to get changes contained by the given document revision.

◆ ACAPI_Revision_GetRVMDocumentRevisions()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMDocumentRevisions ( GS::Array< API_RVMDocumentRevision > *  api_revisions)

Retrieves all document revisions.

Parameters
api_revisionsThe array of the document revisions.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - api_revisions is nullptr.
  • APIERR_GENERAL - Couldn't get the document revisions.
Remarks
This function retrieves all document revisions.

◆ ACAPI_Revision_GetRVMElemChangeIds()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMElemChangeIds ( const API_Guid elemGuid,
GS::Array< GS::UniString > *  api_changeIds 
)

Retrieves the change IDs of the given elem identified by GUID.

Parameters
elemGuidGUID of the element.
api_changeIdsThe array of the change IDs.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - elemGuid or api_changeIds is nullptr.
  • APIERR_BADID - elemGuid does not identify a valid element.
  • APIERR_GENERAL - Couldn't get the change IDs.
Remarks
You are able to get change IDs of the given element.

◆ ACAPI_Revision_GetRVMIssueCustomScheme()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMIssueCustomScheme ( GS::HashTable< API_Guid, GS::UniString > *  customScheme)

Retrieves issue custom scheme.

Parameters
customSchemeContains API_Guid (unique identifier of a custom field), GS::UniString (name of a custom field) pairs.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - customScheme is nullptr.
  • APIERR_GENERAL - Couldn't get the customScheme.
Remarks
This function retrieves custom fields of the API_RVMIssue s.

◆ ACAPI_Revision_GetRVMIssueDocumentRevisions()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMIssueDocumentRevisions ( const API_Guid issueGuid,
GS::Array< API_RVMDocumentRevision > *  api_revisions 
)

Retrieves all document revisions belong to the given issue.

Parameters
issueGuidGUID of the issue.
api_revisionsThe array of the document revisions.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - issueGuid or api_revisions is nullptr.
  • APIERR_BADID - issueGuid does not identify a valid issue.
  • APIERR_GENERAL - Couldn't get the document revisions.
Remarks
You are able to get document revisions contained by the given issue.

◆ ACAPI_Revision_GetRVMIssues()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMIssues ( GS::Array< API_RVMIssue > *  api_issues)

Retrieves all issues.

Parameters
api_issuesThe array of the issues.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - api_issues is nullptr.
  • APIERR_GENERAL - Couldn't get the issues.
Remarks
This function retrieves all issues.

◆ ACAPI_Revision_GetRVMLayoutCurrentRevisionChanges()

GSErrCode __ACENV_CALL ACAPI_Revision_GetRVMLayoutCurrentRevisionChanges ( const API_DatabaseUnId inUnId,
GS::Array< API_RVMChange > *  api_changes 
)

Retrieves all changes belong to the last revision of the given layout.

Parameters
inUnIdThe unique ID of the layout database.
api_changesThe array of the changes.
Returns
  • NoError - The function has completed with success.
  • APIERR_BADPARS - inUnId or api_changes is nullptr.
  • APIERR_GENERAL - Couldn't get the layout database.
Remarks
You are able to get changes contained by the last revision of the given layout.