Archicad 28 C++ API
Loading...
Searching...
No Matches
API_RVMIssue Struct Reference

Represents an Issue. More...

#include <APIdefs_Database.h>

Public Attributes

API_Guid guid
 GUID of the Issue.
 
GS::UniString id
 ID of the Issue.
 
GS::UniString description
 Short description of the Issue.
 
GSTime issueTime
 Issued time of the Issue.
 
GS::UniString issuedByUser
 TW user identifier (full name) who issued the Issue.
 
short userId
 The member ID of the owner in TeamWork mode.
 
bool isOverrideRevisionId
 Corresponds to the "Override Revision ID of all included Layouts" checkbox on the "Issue Details" dialog (see picture below).
 
bool isCreateNewRevision
 Corresponds to the "Create New Revision in all included Layouts" checkbox on the "Issue Details" dialog (see picture below).
 
short visibleMarkersInIssues
 Corresponds to the "Markers visible since" dropdown list on the "Issue Details" dialog (see picture below).
 
bool issued
 Status of the issue (issued or opened).
 
bool filler [5]
 Reserved for later use.
 
GS::HashTable< API_Guid, GS::UniString > customData
 Contains the custom data fields. The custom scheme GUID-value pairs are stored in a GS::HashTable.
 

Detailed Description

Represents an Issue.

Remarks
You can get all issues via ACAPI_Revision_GetRVMIssues function and get the custom scheme of issues via ACAPI_Revision_GetRVMIssueCustomScheme function.
Issue details