Archicad 28 C++ API
Loading...
Searching...
No Matches
API_RVMLayoutInfo Struct Reference

Represents layout meta data in API_RVMDocumentRevision. More...

#include <APIdefs_Database.h>

Public Attributes

GS::UniString id
 ID of the layout.
 
API_DatabaseUnId dbId
 Database unique identifier. Valid only for opened issue.
 
GS::UniString name
 Name of the layout.
 
GS::UniString masterLayoutName
 Name of the master layout.
 
double width
 Width of the layout.
 
double height
 Height of the layout.
 
GS::Array< GS::UniString > drawingScales
 Array of the drawing scales.
 
GS::UniString subsetId
 ID of the subset.
 
GS::UniString subsetName
 Name of the subset.
 
GS::HashTable< API_Guid, GS::UniString > customData
 Contains the custom data fields. The custom scheme GUID-value pairs are stored in a GS::HashTable.
 
short teamworkOwner
 Teamwork owner of the layout.
 
short filler [3]
 Reserved for later use.
 

Detailed Description

Represents layout meta data in API_RVMDocumentRevision.

Remarks
This structure contains layout meta data for API_RVMDocumentRevision.