Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingDistributionData Struct Reference

Represents the distribution of some Railing subelements. More...

#include <APIdefs_Elements.h>

Public Attributes

API_DistribTypeID type
 Distribution of the given pattern: |APIDT_Divisions|Divide segment into patternAmount divisions.| |APIDT_PatternLength|Fixed pattern length.| |APIDT_BestDivisionByLength|Equally distributed pattern. Maximal length is given by length.|.
 
API_PatternAlignID alignment
 Pattern origin position: |APIPA_StartWithPattern|Start with pattern.| |APIPA_StartFromCenter|Start from center.| |APIPA_CenterAligned|Aligned to center.| |APIPA_EndWithPattern|End with pattern.|.
 
double length
 Length between divisions.
 
UInt32 patternAmount
 Amount of the given pattern's repetitions.
 

Detailed Description

Represents the distribution of some Railing subelements.

Member Data Documentation

◆ alignment

API_RailingDistributionData::alignment

Pattern origin position: |APIPA_StartWithPattern|Start with pattern.| |APIPA_StartFromCenter|Start from center.| |APIPA_CenterAligned|Aligned to center.| |APIPA_EndWithPattern|End with pattern.|.

◆ type

API_RailingDistributionData::type

Distribution of the given pattern: |APIDT_Divisions|Divide segment into patternAmount divisions.| |APIDT_PatternLength|Fixed pattern length.| |APIDT_BestDivisionByLength|Equally distributed pattern. Maximal length is given by length.|.