Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingFrameData Struct Reference

Represents the boundaries of a Railing subelement. More...

#include <APIdefs_Elements.h>

Public Attributes

double yOffset
 Horizontal offset from Segment, perpendicularly to the plane of the segment.
 
double zTopOffset
 Offset from top Rail or the top of the Segment.
 
double zBottomOffset
 Offset from bottom Rail or the bottom of the Segment.
 
double xBeginOffset
 Offset from left Inner Post.
 
double xEndOffset
 Offset from right Inner Post.
 
UInt32 placeIndex
 Index of the left Inner Post.
 
API_RailingVerticalPosData verticalPosition
 This structure describes the vertical position of the subelement.
 

Detailed Description

Represents the boundaries of a Railing subelement.